Environment
Security Manager 6.x
Situation
The NetIQ Security Manager Core service will not start. The Core service logs have this line in it: 'Value was either too large or too small for an Int16'
Resolution
To resolve this issue, remove the custom fields that are too large from the MetaDataFieldDefinitiontable in the OnePoint database. The column to look at is the FieldID column. If the value here is above the allowable value for INT16, you will see this error message.
Cause
This value for the dbo.MetaDataFieldDefinition FieldID column is INT16. Any other setting will generate this error, such as a custom module with a field that is too large being added to Security Manager.
Additional Information
Formerly known as NETIQKB71181