Error Message - not licensed to monitor this endpoint (NETIQKB71158)

  • 7771158
  • 23-Jul-2008
  • 06-Apr-2012

Environment

NetIQ Security Solutions for iSeries

NetIQ Secure Configuration Manager 5.7

 

Situation

Core Services: Not licensed to monitor this endpoint error message when running a report against NetIQ Security Solutions for iSeries endpoint.
The report does not apply to this endpoint.

Resolution

To resolve this you will need to remove the system, reset the guids and then replace the endpoint hostname with the ip address.

On your SCM console:
- Open the Secure Configuration Manager (Vulnerability Manager) client.
- Expand IT Assets, Click on Managed Systems, On the right side of the screen, the "List of computers that have been added to the asset map" list shows up.
- Right click on the iSeries system in question and select Delete.
- Click Yes when the "Are you sure you want to delete" dialogue box pops up.
- Click Yes when the "Delete Agent" dialogue box pops up.

- Expand IT Assets -> Discovered Systems

                Left Click on the iSeries endpoint and hit the ?Delete? button.


On the iSeries agent machine:
- From a command line run the following commands:

               ADDLIBLE PSCOMMON
               ENDSBS ZPSE *IMMED
               DSPMSG QSYSOPR to determine subsystem has ended.
               PSRUNSQL REQUEST('DELETE FROM PSCOMMON/PSEGUIDS WHERE TYPEID = 801 or (TYPEID > 52000000 and TYPEID < 53000000)')    CONFIRM(*NO)
               QSH
               
On the QSH Command Entry screen, run the following commands:

               cd  /pentasafe/vsa/cmnagent/script

               resetagent

               Press F3 to exit back to the command line.


Then run commands:

               STRSBS PSCOMMON/ZPSE

On your SCM console:
- Right click on Managed Systems and select Manage system.
- The Manage system System Definition dialogue box should show up.
- Put in the system name in the Name field and change Type to iSeries.
- If the System name used is in your DNS host table or the host table on your PC, then you can try an IP lookup.
- If the IP lookup yields error "Host is not found", then you will have specify the hostname and IP address manually.
- Click on next.
- On the Manage system Register Agent screen, select option "Use local agent already install on this system" leaving the *IP port option to 1622.
- Click on Next.
- On the Manage system Add to End point screen, select the "Add end point to group" option is you want to add the iSeries endpoint to another group in addition to the iSeries group under "Managed Groups"
- Click on Finish.

Cause

The agent is not in synch with Core Services and or the database.

Additional Information

Formerly known as NETIQKB71158