Unable to view all computers in Software Inventory list of Control Center (NETIQKB70945)

  • 7770945
  • 20-Feb-2008
  • 25-May-2011

Environment

NetIQ AppManager 7.0.x

Situation

Unable to view list of machines in the Software Inventory category of Control Center
Unable to access Deployment Web Service web page

Resolution

Configure the Identity tab of the Default Application Pool in Internet Information Services Manager:

  • Launch Internet Information Services Manager from Administrative Tools
  • Expand the Servername, then expand the "Application Pools" category
  • Locate the "DefaultAppPool" object, right click it and go to "Properties"
  • On the Identity tab, change the selection to "Configurable" and supply an AD account that has access to write to the NQCCDB
  • Restart IISAdmin services and restart machine level NetIQMC and NetIQCCM services.

Machines should now start reappearing in the Software Inventory category of Control Center.

Cause

This will happen if the Deployment Web Service is located on a different machine than the NQCCDB.  Problems accessing the Deployment Web Service come up because of the Microsoft Double hop issue.

Additional Information

Formerly known as NETIQKB70945