Environment
Situation
Unable to upgrade Operator Console when updating to AppManager 7.0.1
Resolution
If the key is not available, please create the registry key and try running the AppManager 7.0.1 update installer again. If the Update still does not process, please manually call the AM701_Update_UISetup.msp executable passing the following parameters:
msiexec /p "D:\update\Setup Files\AM701_Update_UISetup.msp" PATCHPACKAGE="UI" SERVICESTOSTOPSTART="netiqmc,netiqccm,netiqms" TERMINATEPROCESS="" SERVICEPACK="1" REINSTALLMODE="omus" REINSTALL="ALL" /L* "C:\Program Files\NetIQ\temp\NetIQ_Debug\AM701_Update_UISetup.msp.log" INSTALLDIR="C:\Program Files\NetIQ\"
Note: If the parameters are not supplied to the Upgrade will not process properly.
Cause
The AppManager 7.0.1 update installer will look for registry key:
HKLM | SOFTWARE | NetIQ | AppManager | ComponentSummary | OperatorConsole
to identify whether the Operator Console was installed or not. If the AppManager 7.0 Operator Console was installed, this key will be available.