Error when passing eventids to an external applications using menu extensions in Control Center. (NETIQKB70666)

  • 7770666
  • 20-Sep-2007
  • 28-Jan-2011

Environment

NetIQ AppManager 6.0.2
NetIQ AppManager Control Center 6.0.2

Situation

Error when passing eventids to an external applications using menu extensions in Control Center.
What does Hotfix 70666 cover for NetIQ AppManager 6.0.2?
Error: 'An unhandled exception has occurred in your application'
Error: 'An unhandled exception has occurred in your application'. If you click Continue, the application will ignore this error and attempt to continue. If you click Quit, the application will be shut down immediately.
Error: 'Specified Cast is not valid' when using menu extensions to pass an eventid to an external application in Control Center 6.0.2.

Resolution

AM602_Hotfix70666 resolves an issue related to an unhandled exception raised by the Control Center Console.

In order to correct this issue, please download and install AM602_Hotfix70666.exe.  The Hotfix can be obtained from the following location:

https://download.netiq.com/KnowledgeDepot/AM/Hotfixes/Recommended/AM602_Hotfix70666.exe

Cause

This problem occurs due to a problem in the NQConsoleExt.dll file in NetIQ AppManager Control Center 6.0.2

Additional Information

Formerly known as NETIQKB70666

Who Should Install this Hotfix?

This hotfix is recommended for all users using AppManager Control Center Console version 6.0.2.


Installing the Hotfix

The AM602_Hotfix70666.exe download package contains the following files:

  • AM602_Hotfix70666_Setup.exe
  • AM602_ReadMe70666.htm

To install this hotfix:

  1. Ensure that the Control Center Console is closed.
  2. Run AM602_Hotfix70666_Setup.exe on all AppManager Control Center Console computers.
  3. After you run AM602_Hotfix70666_Setup.exe, the NQConsoleExt.dll file is updated to version 6.0.1038.1132.

The MAINT.LOG file lists all changes and problems encountered during the installation process. The MAINT.ERR log file lists only the problems encountered. By default, these files are located in the \NetIQ\Temp\NetIQ_Debug folder.


Contacting NetIQ Corporation

Please contact us with your questions and comments. We look forward to hearing from you. Sales Email: info@netiq.com
 
Telephone: 1-713-418-5555 (United States)
+353 (0) 91-782-677 (Europe, Middle East, and Africa)
For other locations, see our Support Contact Information Web site at www.netiq.com/support
 
Support Web Site: www.netiq.com/support