Email Address field does not populate when running an Advanced Query in DRA 8.1 (NETIQKB70665)

  • 7770665
  • 19-Sep-2007
  • 10-Nov-2011

Environment

Directory & Resource Administrator 8.x

Situation

Email Address field does not populate when running an Advanced Query.
When executing an Advanced Query, with the Email Adress column selected in the display window, the field will not populate with any data.

The actual field name we are trying to populate is not email but is called mail. This is the email property off the general tab of users. It is typically populated with the primary SMTP address when the RUS service runs.

Resolution

Workaround:

  1. Go to HKEY_LOCAL_MACHINE\SOFTWARE\Mission Critical Software\OnePoint\Administration\Modules\Accounts\LDAPColumns.
  2. Find the key Email Address email and right click on it and select Rename Change it to read "Email Address mail" instead of "Email Address email".
  3. Restart the MCSAdminSVC.
  4. You have to reload the query in the GUI and rerun it.

 

Cause

The registry key is named improperly.

Additional Information

Formerly known as NETIQKB70665