Unable to view reports within Report Viewer Error: "ASP 113 - the script timed out" (NETIQKB70559)

  • 7770559
  • 02-Aug-2007
  • 25-May-2011

Environment

NetIQ AppManager 6.x
NetIQ AppManager 7.0.x

Situation

Unable to view reports within Report Viewer Error: "ASP 113 - the script timed out"
Unable to see AppManager reports with the Report Viewer application

Resolution

To resolve this issue, please follow the process below:

  1. Open up the Knowledge Script that is being used pull reporting data by double-clicking it
  2. Configure the Expiration setting on the Knowledge Script so that it expires at the desired interval
  3. Configure the DeleteExpiredReports Knowledge Script to run on the Reporting Server managed object from the Operator Console
  4. Give the DeleteExpiredReports Knowledge Script some time to process then relaunch the Report Viewer application

Cause

The amount of reports in the directory AMReports has grown to a number that is too high to manage.  The directory has grown so large that the ReportBinder.asp is not able to finish enumerating all reports.

Additional Information

Formerly known as NETIQKB70559