AppManager Unix Agents gray out in the Operator Console and the Heartbeat doesn't complete (NETIQKB70431)

  • 7770431
  • 20-Jun-2007
  • 13-Sep-2007

Environment

AppManager for Unix 6.5
AppManager 6.0.2

Situation

AppManager Unix Agents are grayed out in the Operator Console and needs to be restarted in order to the start communicating with the Management Server

When the above situation occurs the following is also observed:

No "heartbeat" attempts are observed in NqmAgt.log
HeartBeat Task in the log is listed as "still alive"
LastHeartBeat is greater than 30 seconds from the current time-stamp, or "Never"

Resolution

NetIQ is aware of this problem and have resolved the issue with the release of a patch available by contacting NetIQ Technical Support:

  • This patch will force the agent to disconnect after a set timeout (1 minute) when the HeartBeat task hangs, rather than holding the thread open indefinitely. 
  • After the timeout, the connection will be terminated, and a new HeartBeat will be attempted.  

 

 

Cause

The AppManager Unix Agent may grayout in the Operator Console if there are any communication problem between the Unix Agent machine and the Management Server during a HeartBeat task.  If the HeartBeat task is interrupted for any reason the agent does not cancel the thread, but keeps the connection open indefinitely, or until the agent is restarted.

Additional Information

Formerly known as NETIQKB70431