Discovery_Oracle fails on 64bit Oracle on Windows x64 (NETIQKB70174)

  • 7770174
  • 05-Apr-2007
  • 03-Jun-2011

Environment

NetIQ AppManager 6.x
NetIQ AppManager 7.0.x
AppManager For Oracle Windows module

Situation

Discovery_Oracle fails on 64bit Oracle on Windows x64
Discovery fails with an error Code = 800a0e7a. Description = Provider cannot be found. It may not be properly installed

Resolution

Oracle has provided patches for the Oracle client libraries under Oracle Metalink article 334528.1. You can install the Oracle 10.2 client and the patch for this version found in Oracle Metalink article 334528.1 to correct this issue. 

As an optional workaround to installing the Oracle 10.2 client patch you can install the NetIQ AppManager agent software into another directory not containing parenthesis such as Program Files.

Cause

The Oracle client libraries have an issue when the calling application has a path containing parenthesis.  On Windows x64 systems the default location for a 32bit application such as the AppManager agent is in the Program Files (x86) directory.

Additional Information

Formerly known as NETIQKB70174