Situation
Unable to connect to SQL on upgrade or Database server validation failed the following checks: The Microsoft Distributed Transacation Coordinator Service is not configured correctly at the central computer
Resolution
In order to troubleshoot this, please try the following:
Check for installed application servers
- Open Add/Remove Programs on the Central Computer you are upgrading
- Go into Add/Remove Windows Components
- Go into Application Server
- Ensure that Enable network COM+ access and that Enable network DTC access are enabled
- If one of these items is missing, install it.
Verify that connectivity can be established by testing the ODBC connection
- Open the Data Sources (ODBC) application
- Go to the System DSN tab
- Add a new connection
- Select the SQL Server driver
- Click Finish
- Enter a name in the name field
- Enter the name of the SQL Server in the Server field
- Click Next
- Leave everything at the default and click Next
- Leave everything at the default and click Next
- Leave everything at the default and click Finish
- Click on the button that says Test Data Source...
If there a connectivity problem exists, we can review the log from the test. Find the log in this location for review: .
Cause
This is usually caused by a lack of connectivity from the Central Computer to SQL
Additional Information
Formerly known as NETIQKB56264