Add to Groups icon and right-click task options are missing for non-DRA Admins after ugprade to DRA (NETIQKB55273)

  • 7755273
  • 02-Feb-2007
  • 14-May-2007

Resolution

fact
Directory and Resource Administrator 8.0

symptom
The "Add to Groups" icon and right-click task options are missing for non-DRA Admins after upgrade to DRA 8.0.

symptom
The 'Group Administration' Role no longer allows Assistant Admins to add users to groups.

symptom
DRA Assistant Admins can no longer add users to groups.

cause
The 'Group Administration' Role, while containing the power 'Add Object to Group', is not passing the correct code for it to include Users.

fix

This issue is addressed in NetIQ Directory and Resource Administrator and Exchange Administrator version 8.0 Hotfix 55584.

  • If you are an Assistant Admin with the Add Object to Group power or the Manage Group Memberships role, when you select a user account to add to a group, DRA does not display either the Add to Groups icon in the toolbar or the Add to Groups option in the Tasks menu. This problem occurs because DRA only allows Assistant Admins with the Add User to Group power to add users to groups. This hotfix corrects this issue by allowing Assistant Admins with the Add Object to Group power to add users to groups.

Note: To create mailboxes and mail-enabled user accounts, you should install the System Admin Tools for Microsoft Exchange 2000 or later on the Administration server computer.

Note: This hotfix requires DRA version 8.0

To download and install this hotfix:

  1. Close all DRA user interfaces.
  2. Run the DRA80000_Hotfix55584.msi file on each computer where you installed an Account and Resource Management console or Delegation and Configuration console.

Hotfix 55584 modifies the following files on each computer where you installed an Account and Resource Management console or Delegation and Configuration console. By default, these files are located in the Program Files\NetIQ\DRA folder.

  • NetIQ.DRA.Console.Accounts.dll
  • NetIQ.DRA.Framework.dll

For more information, please contact NetIQ Technical Support at https://www.netiq.com/support .



note

As a workaround to applying the hotfix, add the "Add User to Group" power to the existing ActiveView(s) to also resolve the problem.



note

For more information on this Hotfix, see the following Knowledge Base article:

NETIQKB55584 - "What is the purpose of DRA version 8.0 Hotfix 55584?"



Additional Information

Formerly known as NETIQKB55273