Accounts cache refresh is not completing. (NETIQKB55224)

  • 7755224
  • 02-Feb-2007
  • 14-May-2007

Resolution

fact
Directory and Resource Administrator 8.0

symptom
Accounts cache refresh is not completing.

symptom
FACR appears to hang and not complete.

cause
The DraDomFile.exe file is failing when it is enumerating some groups whose members belong to a different domain.

fix

This issue is addressed in NetIQ Directory and Resource Administrator and Exchange Administrator version 8.0 Hotfix 55224.

Hotfix 55224 corrects an issue with the way Directory and Resource Administrator (DRA) handles the failure of full accounts cache refreshes in some scenarios where DRA is enumerating groups of a particular domain and the group has members that belong to a different domain.

During a full accounts cache refresh in certain scenarios, the DraDomFile.exe file, which performs the caching, fails when it is enumerating groups in a particular domain and the group has members that belong to a different domain. This hotfix includes a workaround to ensure DRA completes the full accounts cache refresh successfully. The workaround requires you to create a text file called DcsToIgnore.txt with entries containing the distinguishedName of the domains to which the group members belong.

Note: You should only add entries for those domains that cause the failure.

For example, if DraDomFile.exe fails when enumerating the group members of domain X, which contains a few group members that belong to domain Y and possibly some other domains, and the failure occurs when processing group members from domain Y, the entry in the text file should contain the value of the distinguishedName attribute of domain Y.

Save this text file in the {InstallDir}\Program Files\NetIQ\DRA\DomFiles folder. Create and set the TruncateGroupMemberships registry key under HKEY_LOCAL_MACHINE\SOFTWARE\Mission Critical Software\OnePoint\Administration to True before performing the full accounts cache refresh.

Note: This hotfix requires DRA version 8.0.

To download and install this hotfix:

  1. Close all DRA user interfaces.
  2. Run the DRA80000_Hotfix55224.msi file on each Administration server computer.

Hotfix 55224 modifies the following files on each computer where you installed an Administration server. By default, these files are located in the Program Files\NetIQ\DRA folder.

  • Accounts.dll
  • DraDomFile.exe

If you require the DraDomFileReader.exe file, contact Technical Support.

For more information, please contact NetIQ Technical Support at https://www.netiq.com/support .



Additional Information

Formerly known as NETIQKB55224