Error: The E-mail address field should not be blank. Enter an address. (NETIQKB55219)

  • 7755219
  • 02-Feb-2007
  • 19-Jun-2007

Resolution

fact
Directory and Resource Administrator 8.0

symptom
Error: The E-mail address field should not be blank. Enter an address.

symptom
Newly created or cloned user accounts that are mailbox or mail-enabled cannot be modified until the RUS has run.

cause
DRA requires the email address field to be populated for mailbox and mail-enabled user objects. If the Recipient Update Service (RUS) has not yet run to generate the email address of the user account, this field is not populated thus resulting in the error.

fix

This issue is addressed in NetIQ Directory and Resource Administrator and Exchange Administrator version 8.0 Hotfix 55584.

  • When you create or clone a user account with a mailbox and then try to edit the user account properties, DRA displays the error message, "The E-mail address field should not be blank. Enter an address." This error occurs because DRA requires an email address for any mailbox or mail-enabled user account. The RUS updates the email address field on a scheduled basis and the email address field may remain empty until you run RUS. This hotfix corrects this issue by simulating RUS for every mailbox or mail-enabled user account and completes the email address field with the email address of that user.

Note: To create mailboxes and mail-enabled user accounts, you should install the System Admin Tools for Microsoft Exchange 2000 or later on the Administration server computer.

Note: This hotfix requires DRA version 8.0

To download and install this hotfix:

  1. Close all DRA user interfaces.
  2. Run the DRA80000_Hotfix55584.msi file on each computer where you installed an Account and Resource Management console or Delegation and Configuration console.

Hotfix 55584 modifies the following files on each computer where you installed an Account and Resource Management console or Delegation and Configuration console. By default, these files are located in the Program Files\NetIQ\DRA folder.

  • NetIQ.DRA.Console.Accounts.dll
  • NetIQ.DRA.Framework.dll

For more information, please contact NetIQ Technical Support at https://www.netiq.com/support .



note

For more information on this Hotfix, see the following Knowledge Base article:

NETIQKB55584 - "What is the purpose of DRA version 8.0 Hotfix 55584?"



Additional Information

Formerly known as NETIQKB55219