Environment
Vivinet Assessor 3.x
Vivinet Diagnostics 2.x
Situation
CHR0125: Endpoint does not support TOS settings for UDP and RTP
Resolution
In order to resolve this verify the following:
- QoS Packet Scheduler is installed as a Service in the Local Area Connection Properties
- Even though most of the latest NICs support 802.1p, this support is usually not enabled at the endpoints by default. Perform the necessary configuration as follows (this example is from Windows 2000):
- Click Start > Settings > Network and Dialup Connections.
- Double-click Local Area Connection and click Properties.
- Click Configure, then click the Advanced tab.
- Change the value to 'enable' if necessary for 802.1p.
- Note - If it is supported by the NIC card, you will see an entry in the list for 802.1p (which may sometimes be called QoS Packet Tagging).
- To allow for assessments with DiffServ definitions on Windows 2000 and Windows XP, an addition to the Registry is required. Add the following DWORD value at the endpoints:
- HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\DisableUserTOSSetting = 0
- Be sure to restart the endpoint computers after you edit their Registry settings. Then run the assessment.
Cause
On Windows 2000 and Windows XP, the QoS Packet Scheduler provides functionality to support 802.1p, although it may not be installed as part of the basic operating system installation. The Packet Scheduler will mark the bit settings based on the QoS service type requested by the application. Currently, the Packet Scheduler can only perform 3 different settings.
Additional Information
Formerly known as NETIQKB54985
Warning: Using the Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. NetIQ Technical Support cannot guarantee that problems resulting from the incorrect use of the Registry Editor can be resolved. Make sure that you back up your Registry prior to making any changes.
Warning: Using the Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. NetIQ Technical Support cannot guarantee that problems resulting from the incorrect use of the Registry Editor can be resolved. Make sure that you back up your Registry prior to making any changes.