Environment
SuSE Linux
Sun Solaris
Red Hat Linux
IBM AIX
HP-UX
AppManager UNIX Agent v6.5
Situation
Cannot send data to the repository.
Error in nqmAgt.log: 'Unable to send data. Queue full. Data text:'
Error in nqmAgt.log: 'Unable to send data. Queue full. Data text:'
Resolution
To limit the queue:
- In a text editor, open netiq/UnixAgent/etc/uaconf.xml.
- Change the value between the <MAX_SIZE> and </MAX_SIZE> tags for the appropriate queues. This value represents the number of bytes to limit the queue to. For instance, to limit the data queue to 1.5 megabytes, you would have a line reading:
<MAX_SIZE>1500000</MAX_SIZE> - Save the file.
- Edit your nqmdaemon script and add the Cold Start Flag to your startup options.
- Restart the agent.
- If you want, remove the cold start flag from nqmdaemon.
note
For more information, see NETIQKB47276: "How do I cold start an AppManager for UNIX v6.5 agent?" at https://www.netiq.com/kb/esupport/consumer/esupport.asp?id=NETIQKB47276
Cause
The queue is full. Log entries found in NqmAgt.log will read similar to this:
Unable to send data. Queue full. Data text:
Instead of "Data", the appropriate queue will be listed. Valid queues are:
- Data, default value of 150000000 (150 million bytes)
- Event, default value of 75000000 (75 million bytes)
- Exception, default value of 15000000 (15 million bytes)
- Status, default value of 10000000 (10 million bytes)
Additional Information
Formerly known as NETIQKB54957