Environment
NetIQ AppManager 6.x
NetIQ AppManager 7.0.x
Discovery_SQL Knowledge Script
NetIQ AppManager 7.0.x
Discovery_SQL Knowledge Script
Situation
Error: 'SQL_DISCOVERY: ClusterDiscovery - ServVersion3 returned lRetVal=-1 strErrorMsg=[Microsoft][ODBC SQL Server Driver][DBNETLIB]SQL Server does not exist or access denied.'
Error: '[Microsoft][ODBC SQL Server Driver][DBNETLIB]ConnectionOpen (Connect()).'
Error: '[Microsoft][ODBC SQL Server Driver][DBNETLIB]ConnectionOpen (Connect()).'
Resolution
To resolve this issue, you must enable TCP/IP protocol for the desired node and instance that you want to discover. If you are running Microsoft SQL Server on a cluster, you must enable the TCP/IP protocol for the node that is currently hosting the desired Microsoft SQL Server instance.
To enable TCP/IP for Microsoft SQL Server 2000:
- In the SQL Client Network Utility, select the General tab.
- Select TCP/IP in the Disabled Protocol list.
- Click Enable.
- Restart the Microsoft SQL Server services.
- Rerun the Discovery_SQL Knowledge Script.
To enable TCP/IP for Microsoft SQL Server 2005:
- In SQL Server Configuration Manager, expand the SQL Native Client Configuration node. If you are using a 64-bit Microsoft SQL Server, select the node for SQL Native Client Configuration (32-bit).
- Click Client Protocols.
- Right click on TCP/IP in the right hand pane and select Enable.
- Restart the Microsoft SQL Server services.
- Rerun the Discovery_SQL Knowledge Script.
Cause
The netiqmc service for the Discovery_SQL Knowledge Script uses NT Authentication and TCP/IP is not enabled in the Client Network Configuration.
Additional Information
Formerly known as NETIQKB54906