When running EMCLI DIRSYNC with the merge method of SamAccountName, the Active Directory user accoun (NETIQKB54378)

  • 7754378
  • 02-Feb-2007
  • 13-Mar-2008

Resolution

fact
Exchange Migrator 2.x

symptom
When running EMCLI DIRSYNC with the merge method of SamAccountName, the Active Directory user account does not get mail enabled, nor does a contact get created.

symptom
"Object cn=<55MbxDN>,cn=Recipients,ou=<Source Site>,o=<SourceOrg>was already synchronized"

symptom
When running EMCLI DIRSYNC with the merge method of SidHistory, the Active Directory user account does not get mail enabled, nor does a contact get created

symptom
"Skipping cn=<55MbxDN>,cn=Recipients,ou=<Source Site>,o=<SourceOrg> which is already synchronized [hr=0]"

cause

The following scenarios could cause this: 

  • The "E-Mail" field of the Active Directory user account's General properties sheet has been populated with an email address, and as a result, Exchange Migrator's EMCLI DIRSYNC utility believes it is already mail enabled.
  • The object is actually already mail or mailbox enabled - (meaning the object has an existing SMTP address assigned to it)
  • The object is already present in the EMCLI DIRSYNC table - (regardless of its presence in Active Directory)


fix

In the first 2 scenarios, EMCLI DIRSYNC will not synchronize an object that has an existing smtp address.  If removing the smtp address is desired, remove the Exchange Attributes from the object using the Exchange Tasks wizard in Active Directory:

  • Launch the Exchange version of Active Directory Users and Computers
  • Locate the Active Directory object(s) that have the "E-Mail" field populated
  • Right click the object(s) and select Exchange Tasks
  • Proceed through the Exchange Tasks wizard and select to Remove Exchange Attributes option
  • Run EMCLI Dirsync again using the /cleartables switch

In the last scenario - As long as there is an entry for the object in the projectname-SynchToTarget table, (where projectname is the name of the project supplied to EMCLI DIRSYNC) - EMCLI DIRSYNC will not attempt to synchronize (mail-enable) the object - (because it thinks it already has based on the information in the table).  If the object if falsely present in the table, or if a contact is created by accident in the Active Directory environment:

  • Delete the Contact in Active Directory
  • Run EMCLI DIRSYNC with the /cleartables switch


note

Reason for running EMCLI DIRSYNC with the /cleartables switch:

  • The first time EMCLI DIRSYNC is run for a project, it creates a new table in Exchange Migrator's EMA database. 
  • This table gets populated with entries that map the Exchange 5.5 mailboxes in the source Recipients container, to the Active Directory user account or contact in the target's OU
  • Each subsequent execution of the Dirsync command (for the same project) will reference thIs table for existing synchronized objects, and if a match is found, it will skip that object and move on to the next.
  • After making the changes in the above fix statement, run the EMCLI DIRSYNC utility with the /cleartablesswitch to ensure a new table is created, so that the object doesn't get skipped as a result of its mapping showing up in that table.


note

For more information on the syntax of running the EMCLI Dirsync command, see:

NETIQKB863:  "What is the syntax and usage for EMCLI DIRSYNC?"

For more information on how Dirsync uses the /cleartables switch, see:

NETIQKB29319:  "What information does Exchange Migrator ignore when the 'EMCLI DIRSYNC /ClearTables' switch is used?"



Additional Information

Formerly known as NETIQKB54378