The NetIQ AppManager Client Communication Manager Service (NetIQccm) will not start. (NETIQKB54194)

  • 7754194
  • 02-Feb-2007
  • 08-Nov-2011

Environment

NetIQ AppManager 7.0.x
NetIQ AppManager Client Communication Manager Service (NetIQccm.exe)

Situation

The NetIQ AppManager Client Communication Manager Service (NetIQccm) will not start.
Error: '[Microsoft][ODBC Microsoft Access Driver] Disk or network error.
Error: 'cmdb-cmdb: failed to connect to db '

Resolution

If the NetIQ AppManager Client Resource Monitor (NetIQmc), and NetIQ AppManager Client Communication Manager (NetIQccm) services are running as a Domain Account, verify that the Domain Account's TEMP and TMP Environment variable path points to a valid path that can be accessed by that domain account.

NOTE: This is a single-valued property and cannot contain multiple paths, for example the entry C:\WINDOWS\Temp;C:\Temp is not allowed.

If the Agent services (NetIQmc & NetIQccm) are running as LocalSystem, verify that the SYSTEM TEMP and TMP variables are pointing to a valid path that can be accessed by the SYSTEM account.

NOTE: This is a single-valued property and cannot contain multiple paths, for example the entry C:\WINDOWS\Temp;C:\Temp is not allowed.

Cause

The path for the TEMP and TMP Environment variables is invalid or inaccessible. When the operating system makes an ODBC connection, it writes a temporary file to the defined TEMP directory when making the initial connection. If it is unable to access the TEMP path it will be unable to open the ODBC connection. You will see the fail to connect error in the ccmtrace.log file on the managed client computer, \Program Files\NetIQ\Temp\<MachineName>\ccmtrace.log. To verify the ODBC error by enabling ODBC logging on the managed client computer:

  1. In Administrative Tools, open Data Source (ODBC).
  2. Select the Tracing tab.
  3. Click Start Tracing Now.

If you are running the agent services as a domain user, the trace log, SQL.LOG, will be dumped in the users' profile directory in a path similar to what is shown in the interface. If your service is set to start as LocalSystem, the SQL.LOG file will be in the %SYSTEMROOT% directory.

Additional Information

Formerly known as NETIQKB54194

For more information about how the connection process determines which variable to use, see to the Microsoft Knowledge Base article "PRB: 'Disk or Network Error' or 'Unspecified Error' Returned when Using Jet http://support.microsoft.com/kb/251254/.