Environment
Situation
Event ID 21177: 'The Agent Manager could not read the processor type, operating system version or Service Pack number from the registry of computer {ComputerName}. No attributes will be collected. The computer will not be considered for Computer Group membership or agent installation.'
Resolution
To check the registry access permissions from the Central Computer to the agent box using the Security Manager service account. Open the registry on the Central computer regedit\file\connect network registry. Connect to the remote agent you are trying to deploy to.
In the remote agent registry verify you have 'Read\Write' permissions to
HKEY_Local_Machine\Software\NetIQ for 32bit
HKEY_Local_Machine\Software\ wow6432node
The Security Manager service account should have 'Read\Write' permissions. If it does not have 'Read\Write' permissions, all access requests to view the registry remotely are denied. 'Read\Write' permissions are needed for Security Manager to start deployment of an agent from the central computer. Modify the setting to grant 'Read\Write' permissions.
Cause
Technical support has found instances where the NetIQ Security Manager Service administrative account being used for agent deployment does not have 'Read\Write' rights on the remote agent registry keys below:
HKEY_Local_Machine\Software\NetIQ - for 32bit
HKEY_Local_Machine\Software\ wow6432node - for 64bit
This permission might have been set by registry lock-down software.Additional Information
Warning: Using the registry editor incorrectly can cause serious problems that may require you to reinstall your operating system. NetIQ Technical Support cannot guarantee that problems resulting from the incorrect use of Registry Editor can be resolved. Make sure that you back up your registry prior to making any changes.