Vulnerability Manager tells me agent metadata is missing when I run a security check. (NETIQKB54156)

  • 7754156
  • 02-Feb-2007
  • 27-Aug-2007

Resolution

fact
NetIQ Vulnerability Manager 5.5

fact
NetIQ Vulnerability Manager Agent for Windows 5.5

symptom
Vulnerability Manager tells me agent metadata is missing when I run a security check.

symptom
Error: 'The 811 agent type metadata is missing.'

cause
The windows.db file is corrupted or contains bad data.

fix

Replace the windows.db file by following the instructions below.

To copy a working version of the windows.db file:

  1. Log on to a machine where the same version of the Windows Agent is installed and is currently working.
  2. Navigate to Program Files > NetIQ > Vulnerability Manager Agent > Data > Windows.
  3. Copy the windows.db file to a share you can access from the machine with the malfunctioning agent.
  4. Log on to the machine with the malfunctioning agent.
  5. Navigate to Program Files > NetIQ > Vulnerability Manager Agent > Data > Windows.
  6. Replace the windows.db file with the file saved on the share.


Additional Information

Formerly known as NETIQKB54156