Resolution
NetIQ Vulnerability Manager 5.5
symptom
I cannot view any reports using the Vulnerability Manager Web Console.
symptom
No reports show up in the Web Console.
symptom
Error: 'Error Code = 15210 com.pentasafe.core.vdal.VdalException: com.jnetdirect.jsql.x: Only members of the sysadmin role can use the loginame option. The password was not changed.'
cause
The default settings for the
VigilEntService
user and/or the settings for the VSMConsole
user have been changed.fix
At startup, NetIQ Core Services changes the password for VSMConsole
. The likely cause is that the default settings for the VigilEntService
user and/or the settings for VSMConsole
user have been changed, therefore preventing the password for VSMConsole
from being successfully changed.
To resolve this issue, you must first make the VigilEntService
account a member of the Security Administrators role, then synchronize passwords between Vulnerability Manager components.
To make VigilEntService
a member of the Security Administrators role:
- Launch SQL Server Enterprise Manager.
- Expand Security > Logins.
- Right-click
VigilEntService
and select Properties. - Click the Server Roles tab.
- Select Security Administrators.
- Click OK.
This should solve the issue unless VSMConsole
has been changed to a higher security level, in which case VigilEntService
must have at least the same higher clearance. Correct security levels as necessary.
To run the password utility on the computer running NetIQ Core Services:
- Navigate to
...\Program Files\NetIQ\Vulnerability Manager\Core Services\Bin
. - Run
PasswordUtility.exe
to reset the password forVigilEntService
.
To ensure the password is successfully reset for theVigilEntService
Login, ensure you set focus to the SQL server where the VigilEnt database exists. When running the VigilEnt database in a Named instance, ensure you select the Named instance when stepping through the Wizard. This password is not required to be complex and will be reset in the next step when the NetIQ Core Services service is restarted. - Open the Services Administrative Tool.
- Right-click NetIQ Core Services.
- Click Restart.
- Log in to the Web console and view reports.