NetIQ CC ManagementGroup <servername> QDB job fails (NETIQKB54070)

  • 7754070
  • 02-Feb-2007
  • 13-Nov-2007

Environment

AppManager 6.0.2
Control Center 6.0.2

Situation

[ SQL JOB: NetIQ CC ManagementGroup [xxxxx.QDB]] [ SQL STEP: Sync management group & member ] Executed as user: domain\user. Cannot use SAVE TRANSACTION within a distributed transaction.

Resolution

NetIQ is aware of this problem and has resolved this with the release of Hotfix 54070. This hotfix resolves the job failure by selectively removing all the SAVE TRANSACTION statements that run in distributed transactions

This hotfix should be applied in environments where you are running the AppManager repository computer(s) managed by AppManager Control Center version 6.0.2.

Cause

The Control Center database periodically executes a job named NetIQ CC ManagementGroup <servername>.QDB, which contains a procedure to fetch/transmit data from/to a repository computer. This procedure contains the SAVE TRANSACTION statement.

If the Control Center database and the repository computer(s) are installed on different servers and if MS SQL Server Service Pack 4 (SP4) is installed on either of these servers, then MS SQL SP4 does not support the SAVE TRANSACTION statement in a distributed transaction. As a result, the NetIQ CC ManagementGroup <servername>.QDB job fails.

(Note: This problem does not occur if you have installed MS SQL SP3 or SP3a.)

Additional Information

Formerly known as NETIQKB54070

This hotfix must be applied only after you have applied the AMCC6021Maintenance.exe hotfix on AppManager Control Center 6.0.2. The AMCC6021Maintenance.exe hotfix is available at the following location: https://www.netiq.com/support/am/hotfixes/default.asp#1289

To install this hotfix:

  1. Download the installation package (AM602_Hotfix54070.exe). https://download.netiq.com/KnowledgeDepot/AM/Hotfixes/Recommended/AM602_Hotfix54070.exe
  2. Extract the contents of the download package (this ReadMe file, and the setup program) to a specified folder. The default location is C:\Program Files\NetIQ.
  3. Run the hotfix setup program, AM602_Hotfix54070_Setup.exe, on all repository computers managed by AppManager Control Center version 6.0.2.