How do I remove duplicate entries for licensed products from the Purchase and Demo Screen? (NETIQKB53911)

  • 7753911
  • 02-Feb-2007
  • 13-Jul-2007

Resolution

goal
How do I remove duplicate entries for licensed products from the Purchase and Demo Screen?

fact
NetIQ Security Solutions for iSeries 8.0

fact
VigilEnt Security Agent for iSeries 7.5

symptom
I have multiple records for the same licensed product on PSMENU option 80 (Enter access codes).

cause
If the license key file is in use during the product upgrade process, the license key records are not deleted before new records are added.

fix

To delete duplicate records that appear on the Purchase and Demo Screen, perform the following steps:

  1. On the iSeries command line, type CALL QCMD and press Enter.
  2. Type CPYF FROMFILE(PSCOMMON/PSPF01) TOFILE(PSCOMMON/PSPF0175) MBROPT(*ADD) CRTFILE(*YES) and press Enter.
  3. Type ADDLIBLE PSCOMMON and press Enter.
  4. Type PSRUNSQL REQUEST('delete from PSCOMMON/PSPF01 F1 where RRN(F1) > (select MIN(RRN(F2)) from PSCOMMON/PSPF01 F2 where F2.PROD = F1.PROD and F2.DESC = F1.DESC)') CONFIRM(*NO) and press Enter.
  5. Type RMVLIBLE PSCOMMON and press Enter.


Additional Information

Formerly known as NETIQKB53911