Error: RPG procedure AP0034R in program PSCOMMON/AP0034R at statement *INIT Called program or proce (NETIQKB53877)

  • 7753877
  • 02-Feb-2007
  • 18-May-2007

Resolution

fact
PSDetect 7.5

fact
PSDetect 8.0

fact
NetIQ Security Solutions for iSeries 8.0

fact
VigilEnt Security Agent for iSeries 7.5

symptom
Error: "RPG procedure AP0034R in program PSCOMMON/AP0034R at statement *INIT Called program or procedure strwizard, which ended in error."

symptom
Error: "The call to run Wizard ended in error (C G D F)"

symptom
PSDetect Wizard displays a ?Wizard Info Error? window with message ?This wizard is currently being used by XXXXXXXXXX.  You are ZZZZZZZZZZ.?

cause
A previous interactive job running the PSDetect Wizard ended abnormally.

fix

Turning off power to the workstation device or using System Request option 2 (End previous request) while in the RRM Configuration Wizard may cause an error or show the Wizard is in use.

To reset the PSDetect Wizard:

  1. Signoff from all sessions where you have tried running the Wizard since the error occurred.
  2. Signon to the iSeries server.
  3. On the iSeries command line, type WRKOBJLCK OBJ(AP0030F) OBJTYPE(*FILE) MBR(*FIRST) and press Enter to identify each job using the Wizard.
  4. End each job identified by the WRKOBJLCK command.
  5. On the iSeries command line, run the following commands:

    ADDLIBLE PSCOMMON

    PSRUNSQL REQUEST('update pscommon/AP0030F set C30USER = ''*AVAILABLE'' where c30wid = 6 and C30USER <> ''*AVAILABLE''')

    RMVLIBLE PSCOMMON

  6. Run the PSDetect Wizard.


Additional Information

Formerly known as NETIQKB53877