Resolution
Directory and Resource Administrator 6.x
fact
Directory and Resource Administrator 7.x
symptom
Mail-enabled groups whose name contains the '#' character have it replaced with the '?' character in the surname of their X400 (X.400) address.
symptom
Mail-enabled contacts whose name contains a pound sign have it replaced with the '?' character in the last name of their X400 (X.400) address.
symptom
Mail-enabled or mailbox-enabled users whose name contains an octothorp have it replaced with the '?' character in the surname of their X400 (X.400) address.
cause
The '#' character is not a valid character in an X.400 address.
fix
DRA and native tools such as ADU&C only allow certain printable string type characters as valid characters for an X.400 address. The following table lists the allowable X.400 address characters:
| Character | Designation |
| A,B,...,Z | Capital letters |
| a,b,...,z | Small letters |
| 0,1,....,9 | Digits (Numbers) |
| (space) | Space |
| ' | Apostrophe |
| ( | Left parenthesis |
| ) | Right parenthesis |
| + | Plus sign |
| , | Comma |
| - | Hyphen |
| . | Full Stop (Period) |
| / | Solidus (Forward slash) |
| : | Colon |
| = | Equal sign |
| ? | Question Mark |
Though you can manually edit and change the ? to the #, the X.400 address will not recognize the # character and email sent to this X400 address will receive Non-Deliverable Receipts (NDRs). To correct the X400 address so that it can receive email, the Group/Contact/User must be renamed without the # character.
SMTP addresses allow the # character and are not affected.
note
For more information about X400 addresses and allowable characters, see the Microsoft Knowledge Base article: http://www.microsoft.com/technet/prodtechnol/sbs/45/reskit/part2/sbrk0215.mspx?mfr=true .