Environment
NetIQ AppManager 6.x
NetIQ AppManager 7.0.x
Situation
Jobs stay in pending state or experience a long delay on the agent.
Management Server is slow and unresponsive.
Events generated by agents are delivered slowly.
Hundreds of EventID 2000 events in the System Event log.
Running a NetIQctrl stat command reveals high callback times:
--------------------------- Event IOC---------------------------
event ioc thread total: 1event ioc thread busy: 1
event ioc total: 174event ioc complete: 1event ioc wait: 1
event client total: 174event client bind: 0event client wait: 0
event callback count: 174event callback time: 16568839average event callback: 95223.21 (ms)
--------------------------- Job Status Change IOC---------------------------
Management Server is slow and unresponsive.
Events generated by agents are delivered slowly.
Hundreds of EventID 2000 events in the System Event log.
Running a NetIQctrl stat command reveals high callback times:
--------------------------- Event IOC---------------------------
event ioc thread total: 1event ioc thread busy: 1
event ioc total: 174event ioc complete: 1event ioc wait: 1
event client total: 174event client bind: 0event client wait: 0
event callback count: 174event callback time: 16568839average event callback: 95223.21 (ms)
--------------------------- Job Status Change IOC---------------------------
Resolution
To resolve this issue, see the Microsoft Knowledge Base article 907404: "The computer may stop responding after you install hotfix 839406, security update 896422, or Update Rollup 1 for Windows 2000 SP4 on a Windows 2000-based computer." http://support.microsoft.com/kb/907404/
Cause
The following Microsoft hotfixes impact Management Server performance:
Additional Information
Formerly known as NETIQKB53094