NetIQ License Audit QDB job error: Could not find stored procedure 'dbo.CiscoCallMgrLicenseCount (NETIQKB52626)

  • 7752626
  • 02-Feb-2007
  • 28-Feb-2012

Situation

After running the SQL Statemant, that the Job uses, error message:
Server: Msg 2812, Level 16, State 62, Line 148
Could not find stored procedure 'dbo.CiscoCallMgrLicenseCount'.
Server: Msg 50000, Level 18, State 1, Procedure licensesproc_CallMgr, Line 151
licensesproc_CiscoCallMgr: Error executing
CiscoCallMgrLicenseCount for lviewname = CiscoCallMgr
The stored procedure does not exist in the database.

Resolution

The stored procedure must be re-created. This can be achieved by installing the NetIQ AppManager Version 6.0.2 Cisco CallManager Update which will create a new stored procedure, so even if it is missing or has been deleted it will be created.

These are the instructions from the readme file:

Installing the update:

Take the following steps to install the update:

  • Extract the contents of ENG186484-CompLic.zip to a temporary folder on the repository computer.
  • Open a command prompt and navigate to the temporary folder.
  • Run the following command: "C:\Program Files\Microsoft SQL Server\80\Tools\Binn\osql.exe" -S ["name of computer that houses repository"] -d ["name of repository"] -U ["login"] -P ["password"] -i rpCiscoCallMgrsprocs.sql
    Note: If your osql.exe is not installed in C:\Program Files\Microsoft SQL Server\80\Tools\Binn, then enter the appropriate file path

Finally, re-run the Net Licence Audit QDB job, which should now complete successfully.

Cause

dbo.CiscoCallMgrLicenseCount stored procedure is missing.

Additional Information

Formerly known as NETIQKB52626