BES_OrphanedUsers knowledge script generates an internal failure error on the MAPI profile. (NETIQKB52555)

  • 7752555
  • 02-Feb-2007
  • 15-Feb-2011

Environment

NetIQ AppManager 6.x
NetIQ AppManager 7.0.x
BlackBerry Enterprise Server (BES) 4.0
BES_OrphanedUsers Knowledge script

Situation

Error: 'Extended Information: Initializing the MAPI subsystem failed.'
Cannot logon using MAPI profile.
Error: '-2147221231.'
Error: 'The MAPI logon did not succeed. This could be due to an incorrect MAPI profile or too many open sessions.'

Resolution

Manually create a MAPI profile on the system and specify that profile in the BES_OrphanedUsers job:

  1. Login to the BES server as the account the NetIQ AppManager Agent services are running as.
  2. Open a command prompt.
  3. Run the prof.exe command using the following synatx: 

    prof.exe -s <ExchangeServerName> -m <MailboxAliasName> -notm -p <ProfileName> 
  4. If you received a return code of 0, then the command was successful.  If you receive any other return code, see the NetIQ Knowledge Base NETIQKB3367: "How do I create a mailbox profile without a mapi client installed on an exchange server using the prof.exe provided with AppManager?" at www.netiq.com/kb/esupport/consumer/esupport?id=NETIQKB3367.
  5. Modify the values for the BES_OrphanedUsers job and specify the profile you created in step 3 and run the Knowledge Script again.

Cause

The correct profile name is specified in the BES_OrphanedUsers script.  The NetIQ AppManager Agent service account must have a profile on the BES server, and that profile must be specified in this script.

Additional Information

Formerly known as NETIQKB52555