AIX agent does not automatically start when the computer is rebooted. (NETIQKB52284)

  • 7752284
  • 02-Feb-2007
  • 15-Oct-2007

Environment

AppManager for UNIX 6.5

Situation

Unix agent will not restart after rebooting the server.

Unix agent is not in the startup list.

Resolution

To fix this problem, make sure there is only one nqmdaemon script and that all the system startup scripts refer to it through a symbolic link so modifications to the nqmdaemon file will affect all run levels.  This keeps the environment clean by making only one nqmdaemon file, and preventing old copies from previous NetIQ AppManager for UNIX from mistakenly being run.

  1. Ensure that /etc/rc.d/rc2.d/S99nqmdaemon is a symbolic link to /etc/nqmdaemon by executing the command "ls -l /etc/rc.d/rc2.d/".  The output should resemble:

    # ls -l /etc/rc.d/rc2.d
    total 48
    -rwxr--r--   3 root     staff          8613 Mar 29 13:30 S99nqmdaemon

  2. If S99nqmdaemon is not a symbolic link, create one by removing the incorrect file and creating a link:
    • rm /etc/rc.d/rc2.d/S99nqmdaemon
    • ln -s /etc/nqmdaemon /etc/rc.d/rc2.d/S99nqmdaemon

  3. Verify that it is now a symbolic link by issuing the command in step 1:

    # ls -l /etc/rc.d/rc2.d
    total 24
    lrwxrwxrwx   1 root     system           14 Apr 06 14:18 S99nqmdaemon -> /etc/nqmdaemon
  4. Repeat these steps for all init directories your system uses:  rc1.d, rc3.d, and so on.

Cause

NetIQ Technical Support has determined that the installation program does not properly register the UNIX agent service script as a system service to run at startup.

Additional Information

Formerly known as NETIQKB52284

If you are running Red Hat Linux, see NETIQKB51719 at https://www.netiq.com/kb/esupport/consumer/esupport.asp?id=NETIQKB51719

For information on the startup lists for various operating systems, see NETIQKB13345: "Where is the AppManager for Unix startup script located?" at https://www.netiq.com/kb/esupport/consumer/esupport.asp?id=NETIQKB13345.