Environment
AppManager 6.5
AppManager Reporting Extras
AppManager Reporting Extras
Situation
SQL Reporting Services (SRS) Error: Arithmetic overflow error converting expression to data type int.
Error: 'Biased Time is a Negative Number.'
Data reports using AppManager Reporting Extras failed with an error condition stating values could not be converted to int.
Error: 'Biased Time is a Negative Number.'
Data reports using AppManager Reporting Extras failed with an error condition stating values could not be converted to int.
Resolution
To resolve this issue, apply the hotfix described in the NetIQ Knowledge Base article NETIQKB51991 at www.netiq.com/kb/esupport/consumer/esupport.asp?id=NETIQKB51991. This hotfix corrects the data collection.
However, the reports may still fail for some period of time, because the data collected prior to the hotfix being applied still exists in the database.
Cause
Java UA reports a real number for the BiasedTime in a datastream. NetIQ Technical Support has determined that the 6.5 agent has a known issue where an offset is returned. The offset is either 0 or a negative number, and is stored directly in the repository.
Additional Information
Formerly known as NETIQKB51865
For more information about BiasedTime, see the NetIQ Knowledge Base article NETIQKB47520 at www.netiq.com/kb/esupport/consumer/esupport?id=NETIQKB47520.