Exchange-RT module jobs fail in environment using Exchange 2003 RPC over HTTP feature of Outlook (NETIQKB51577)

  • 7751577
  • 02-Feb-2007
  • 27-Jan-2011

Environment

NetIQ AppManager 6.x
NetIQ AppManager 7.0.x
NetIQ AppManager ResponseTime for Microsoft Exchange

Situation

Exchange-RT module jobs fail in environment that uses the Exchange 2003 RPC over HTTP feature of Outlook 2003.

Error: 'Exchange Error 0x803A1001: Unable to open Exchange database. OpenMsgStore failed. Error Code: 0x80040111 Source: MAPI 1.0< Error Message: The information store could not be opened.'

When I connect to Microsoft Exchange Server 2003 computer using the Exchange RPC over HTTP feature of Microsoft Office Outlook 2003, I am prompted to provide user account credentials.

Resolution

The authentication mechanism must be set to NTLM authentication with the LmCompatibilityLevel registry setting to a value of two or higher.  If you are currently using NTLM authentication, ensure the LmCompatibilityLevel registry setting on the client machine that Exchange-RT is installed on must has a value of two or higher.

For more detailed information on authentication and how to change this registry value, see the Microsoft article http://support.microsoft.com/?kbid=820281.

 

Cause

Authentication for the Exchange Response Time does not work with Basic authentication. The authentication mechanism that is configured in Outlook 2003 is using Basic authentication or the authentication mechanism that is configured in Outlook 2003 is using NTLM authentication, however the registry values for LmCompatibilityLevel on client is set to value of 0 or 1.

Additional Information

Formerly known as NETIQKB51577

Additional information can be found here: http://support.microsoft.com/kb/823659.