Resolution
fact
Security Manager 5.1
fact
Security Manager 5.5
symptom
Error: 'OpenFailed Error code: Not enough storage is available to process this command'
symptom
The NetIQ Security Manager service was unable to create a critical persistent queue file and cannot process any events.
symptom
Event ID 21236
cause
The temporary storage space is set too large in the global settings for the agents or central computers. When the size is too large, Security Manager cannot create the files and generates an error.
fix
note
Warning: Using the Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. NetIQ cannot guarantee that problems resulting from the incorrect use of Registry Editor can be resolved. Make sure that you backup your Registry prior to making any changes.
Security Manager 5.1
fact
Security Manager 5.5
symptom
Error: 'OpenFailed Error code: Not enough storage is available to process this command'
symptom
The NetIQ Security Manager service was unable to create a critical persistent queue file and cannot process any events.
symptom
Event ID 21236
cause
The temporary storage space is set too large in the global settings for the agents or central computers. When the size is too large, Security Manager cannot create the files and generates an error.
fix
To resolve this issue, modify the temporary storage setting on agents and central computers.
To modify the temporary storage setting on agents and central computers:
- Change the global setting for the central computers to less than 500000 KB by completing the following steps:
a. Log on to the Monitor Console computer using an account that is a member of the OnePointOp ConfgAdms group.
b. Start the Monitor Console in the NetIQ Security Manager program group.
c. In the left pane, expand Security Manager Monitor Console > Configuration.
d. Click Global Settings.
e. On the Action menu, click Edit Central Computer Settings.
f. On the Temporary Storage tab, specify a value less than 500000 KB.
g. Click OK. - Change the global setting for the agents to less than 10000 KB by completing the following steps:
a. Log on to the Monitor Console computer using an account that is a member of the OnePointOp ConfgAdms group.
b. Start the Monitor Console in the NetIQ Security Manager program group.
c. In the left pane, expand Security Manager Monitor Console > Configuration.
d. Click Global Settings.
e. On the Action menu, click Edit Agent Settings.
f. On the Temporary Storage tab, specify a value less than 10000 KB.
g. Click OK. - Modify the MaxFileSize registy entry to decimal 3000 on each agent computer that is experiencing this error. This registry entry is located in
HKEY_LOCAL_MACHINE\SOFTWARE\NetIQ\Security Manager\Configurations\Security\Operations\Agent - Modify the MaxFileSize registy entry to decimal 45000 on each central computer that is experiencing this error. This registry entry is located in
HKEY_LOCAL_MACHINE\SOFTWARE\NetIQ\Security Manager\Configurations\Security\Operations\Consolidator - Restart the NetIQ Security Manager service on the agents and central computers experiencing this error.
note
Warning: Using the Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. NetIQ cannot guarantee that problems resulting from the incorrect use of Registry Editor can be resolved. Make sure that you backup your Registry prior to making any changes.
Additional Information
Formerly known as NETIQKB51240