An error occurs when attempting to run the Module Installer from the Monitor Console or editing a co (NETIQKB51044)

  • 7751044
  • 02-Feb-2007
  • 16-May-2007

Resolution

fact
Security Manager 5.1

fact
Security Manager 5.1 SP1

symptom
An error occurs when attempting to run the Module Installer from the Monitor Console or editing a correlation rule in the Development Console.

symptom
Error: 'An unhandled exception has occurred in your application.'

symptom
Error: 'Security Manager generated an internal error.  Please see the logs.'

symptom
Error: 'An unhandled exception has occurred in your application. If you click Continue, the application will ignore this error and attempt to continue. If you click Quit, the application will be shut down immediately.  Object reference not set to an instance of an object.'

symptom

Error: 'A C++ exception occurred while checking the software license. Possible causes include:
 
 -The license could not be read from the database.
 -The license dll is not installed.
 -The license dll is not registered.

More information about the exception follows.

Type: unknown
Additional information: none
File: \WFLicense.cpp
Line: 96
Other location: LicenseChecker::CheckLicense'



cause
This issue is caused by incomplete license registration. License registration does not complete if the Security Manager installation process is terminated before completion.

fix

To correct this issue, register the license DLLs.

To register the license DLLs:

  1. Open the command prompt on the central computer.
  2. Change to the OnePoint directory where you installed Security Manager, typically as follows:

cd c:\program files\netiq security manager\onepoint

  1. Enter the following commands at the prompt:

    regsvr32 eemlicense.dll
    regsvr32 mcslicense.dll
  2. If either of these files do not exist, reinstall Security Manager, making sure to apply the latest service pack and hotfixes.

 



Additional Information

Formerly known as NETIQKB51044