Environment
NetIQ Analysis Center 2.x
Situation
A SQLOLEDB error is generated when a Data Warehouse in a cluster server and Data Mart in a non-cluster server.
An error is reported when I try to select a data source.
Error: 'The operation could not be performed because the OLE DB provider 'SQLOLEDB' was unable to begin a distributed transaction.'
An error is reported when I try to select a data source.
Error: 'The operation could not be performed because the OLE DB provider 'SQLOLEDB' was unable to begin a distributed transaction.'
Resolution
Enable DTC transactions for the component servers. You can usually enable DTC Transactions on all servers with any SQL component. If you cannot, you must first disable RPC security.
To disable RPC Security for the Microsoft DTC Service on SQL Server:
- Back up the registry.
- Click Start > Run.
- Enter Regedt32.
- Click OK.
- Select HKEY_LOCAL_MACHINE > SOFTWARE > Microsoft.
- Right-click MSDTC > New> DWORDValue.
- Rename the key from the default New Value #1 to TurnOffRpcSecurity.
- Double-click the new key.
- Change the value to 1.
- Close the Registry Editor.
- Restart the SQL Server.
For more information, see the Microsoft Knowledge Base article 555017 at http://support.microsoft.com/?kbid=555017.
Cause
Windows 2003 is trying to use DTC transactions across non-domain environments. The Analysis Center Data Warehouse was installed on a clustered SQL server while the Data Mart was installed on a non-clustered SQL server, and Windows 2003 is trying to use server communication between a domain and a workgroup configuration.
Additional Information
Formerly known as NETIQKB50994
Warning: Using the Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. NetIQ Technical Support cannot guarantee that problems resulting from the incorrect use of Registry Editor can be resolved. Make sure that you backup your registry prior to making any changes.
Warning: Using the Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. NetIQ Technical Support cannot guarantee that problems resulting from the incorrect use of Registry Editor can be resolved. Make sure that you backup your registry prior to making any changes.