How do I stop 7769 errors from halting services? (NETIQKB50859)

  • 7750859
  • 02-Feb-2007
  • 15-Mar-2013

Environment

NetIQ Group Policy Guardian 2.0 SP1

Resolution

goal
How do I stop 7769 errors from halting services?

fact
NetIQ Group Policy Guardian 2.0 SP1

fact
You are monitoring Windows 2003 Domain Controllers without Microsoft Hotfix KB 902346 installed on those domain controllers.

symptom
When you start the NetIQ GPG Host Service, you get 7769 errors in the Application Event Logs indicating "WMI Error: Call Cancelled"

symptom
7769 error messages in the Application Event logs on start of WMI queries.

symptom
GPG does not appear to be collecting events.

cause
This error is due to the use of queries that require Microsoft Hotfix KB 902346.

fix

Warning: This SQL Query directly accesses your database and updates/deletes data. If the query is performed incorrectly it can cause irreparable harm to the database and may result in loss of data. If you are unfamiliar with SQL or how to run a SQL Query please contact NetIQ Technical Support directly.

To resolve the issue with 7769 errors:

  1. Download the file https://download.netiq.com/kb/files/queryupdate2.sql to the GPG database server computer.
  2. Rename the file to UpdateQueries.sql.
  3. Stop the NetIQ GPG Host Service and NetIQ GPG Control Service on the GPG database server computer.
  4. From a command prompt, run osql -E -i <path to UpdateQueries.sql> (for example: osql -E -i C:\UpdateQueries.sql).
  5. Start the NetIQ GPG Host Service and NetIQ GPG Control Service on the GPG database server computer.


note

It may take up to 5 minutes for the Server to send the updated query information to any collectors (the built-in collector is automatically updated on restart).



Additional Information

Formerly known as NETIQKB50859