Environment
NetIQ AppManager 7.0.x
Situation
Error: 'Failed to retrieve printer queue info. Please check if mc run as NT domain account. Otherwise, printer name is invalid.'
NT_PrinterQueue is not able to enumerate the print queues.
Resolution
To determine the actual network or system issue preventing Windows from connecting to the specified printer:
- Log on to the Managed Client as the netiqmc service account.
- Click Start> Run.
- Enter cmd and click OK.
- Using the PrintServerName and PrintShareName values as specified in the KS parameters, execute the command:
cmd /c net print \\{PrintServerName}\{printShareName} > c:\Progra~1\NetIQ\Temp\9999.tmp
When you determine the issue preventing Windows from connecting to the specified printer, you will know what action to take to resolve the issue, for example:
- Use an NT Domain Account rather than LocalSystem for the netiqmc service account.
- Specify the correct printer name or share.
- Resolve the network or system issue as designated by Microsoft pertaining to the error message that is returned from running the net print test command.
Cause
A network or system issue is preventing Windows from connecting to the specified print server share. For example, the NetIQ AppManager Client Resource Monitor Service (netiqmc service) account might not have permissions to the specified print server share, or an incorrect printer name might have been specified.
Additional Information
Note that this KS is not designed to monitor printers on the network. It is designed to monitor printers being hosted on the network by a given server. However, those servers must be set up as a local printer on that server for this KS to work.
The KS might successfully monitor networked printers which are not set up as local printers on the server where this job is running, but if it is unsuccessful, set the printer as a local printer.