Error when attempting to view Graph Data Details for graphs generated using data from SQL KSes (NETIQKB50538)

  • 7750538
  • 02-Feb-2007
  • 10-May-2011

Environment

NetIQ AppManager 6.x
NetIQ AppManager 7.0.x

Situation

Error when attempting to view Graph Data Details for graphs generated using data from SQL_TopXXXUsers jobs.

When I try to see Graph Data Details for graphs made from information collected by SQL_TOPXXXUsers jobs, I get an error.

Graphs can be generated based off of data collected by the SQL_TopXXXUsers jobs, but I get an XML error when attempting to view Graph Data Details for some or all points of those graphs.

Error: 'Failed to load XML data required to render HTML table.'

Resolution

To confirm that this Knowledge Base article applies to your specific issue:

  1. In SQL Query Analyzer, select your AppManager repository as the target for your queries.
  2. On the Tools menu, click Options.
  3. Select the Results tab.
  4. For Default Results Target, select Results to Grid.
  5. In Maximum Characters per Column, enter 8000.
  6. Run the following query against the repository:

    select coalesce(Detallong, Detailshort) from dbo.Data where DataID - <ChildDataID>

    Get the Child DataID from the Graph Data pane of your Operator Console for data collected by one of the SQL_TopXXXUsers jobs with the problem.
  7. Copy the output that this query will generate into an editor such as Notepad.
  8. Save the file using a .txt extension.
  9. In Windows Explorer, rename the extension of the .txt file to .xml.
  10. Open the .xml file in a Web browser to display an XML error.
  11. Using the information in the error, make a note of the specific line and character position value of the failure point.
  12. Close the window, and rename the file back to .txt format.
  13. Open the file in an editor such as Notepad.
  14. Locate the appropriate line of affected data, count to the appropriate character position on that line to locate the special character causing these errors.

The problem character must be a "®" for this Knowledge Base article to apply, and for the fix offered in this article to correct the problem.  If the special character causing your issue is not a "®" symbol, contact NetIQ Technical Support directly for additional assistance, and do not apply the fix offered in this Knowledge Base article.

Cause

NetIQ Technical Support has determined that the affected Knowledge Scripts have a known problem with parsing the special character "®" from the data that is returned by these jobs. NetIQ Corporation plans to correct this problem in a future version of the SQL Module for AppManager.

Additional Information

Formerly known as NETIQKB50538

For assistance in checking Knowledge Scripts in, see the Knowledge Base article NETIQKB25185: "How do I check in an AppManager Knowledge Script?" at https://www.netiq.com/kb/esupport/consumer/esupport.asp?id=NETIQKB25185.