Cannot run a check created with the Custom Check Wizard. (NETIQKB50365)

  • 7750365
  • 02-Feb-2007
  • 17-Apr-2008

Resolution

fact
NetIQ Vulnerability Manager 5.0

fact
NetIQ Vulnerability Manager 5.5

symptom
Cannot run a check created with the Custom Check Wizard.

symptom

Error: 'Failed to get Windows_OU xxxxxx/xxxxxxx/xxxxx in DC=xxxxxxx, DC=xxxxxxxx. There is no such object on the server'



symptom
I get an error when I try to run a custom Security Check.

symptom
Custom check with a nested OU Path as a parameter causes an error in Vulnerability Manager.

cause

A bug in the Custom Check Wizard causes this error. When you enter a nested organizational unit (OU) path (OU1/OU2/OU3), the wizard sees it as a single OU name instead of a nested path containing three OU names and replaces it with a default OU string.



fix

To fix this problem:

  1. In the VM Console, navigate to NetIQ Vulnerability Manager > Security Knowledge > Security Checks > My Checks and select the check that causes the error.
  2. On the Actions menu, click Export Security Check.  Save the check to a location where you can find it easily.
  3. In Windows Explorer, browse to the location where you saved the check.  Right-click on the check file and select Open With.  Choose any text editor (for example, WordPad, Notepad, or ConTEXT) to open the file.
  4. Search for the following string in your check file:  Windows_OU=%{ORGANIZATIONAL UNIT NAME}.
  5. Attach the other OUs in your nested OU path at the end of the existing OU string, with a '/' between each OU string. See the example below:

    OU Path:Departments/Canada/Users
    Original OU String:Windows_OU=%{ORGANIZATIONAL UNIT NAME}
    Modified OU String:Windows_OU=Departments/Windows_OU=Canada/Windows_OU=Users

  6. Save your changes to the check file.
  7. Go back to the VM console and navigate to NetIQ Vulnerability Manager > Security Knowledge > Security Checks > My Checks.  Find the check that you exported in Step 2.
  8. On the Actions menu, click Delete Security Check.  You need to delete the original version of the exported check in order to be able to import the modified version.
  9. Click on My Checks in the Tree Pane and then click Import Security Check on the Actions menu.
  10. Browse to the location where you saved the check in Step 2.  Select the check and click Open.
  11. Re-run the modified check.


Additional Information

Formerly known as NETIQKB50365