Environment
NetIQ AppManager 6.x
NetIQ AppManager Control Center 6.x
Situation
Distributed Transactions Coordinator (DTC) guid identifier does not work.
Resolution
To eliminate the duplicate ID, either:
- Use GuidGen to create a new GUID and update DTC registry with the new GUID as described in the Microsoft Knowledge Base article, Troubleshoot MS DTC Firewall Issues, which can be found at http://support.microsoft.com/default.aspx?scid=kb;EN-US;306843.
or - Reinstall DTC:
- Windows 2000: Perform the steps in the Microsoft Knowledge Base article, How to reinstall MS DTC for a nonclustered Windows 2000 Server, which can be found at http://support.microsoft.com/default.aspx?scid=kb;EN-US;279786.
- Windows 2003: Perform the steps in the Microsoft Knowledge Base article, How to reinstall MS DTC for a nonclustered Windows 2000 Server, which can be found at http://support.microsoft.com/default.aspx?scid=kb;EN-US;279786 except when you reinstall MSDTC, use the command msdtc -install. Also, enable Network Access as described in You Receive Error 7391 When You Run a Distributed Transaction Against a Linked Server, which can be found at http://support.microsoft.com/default.aspx?scid=kb;en-us;329332
- Windows NT: Perform the steps in the Microsoft Knowledge Base article, Reinstall MSDTC for a non-clustered Windows NT 4.0 Server, which can be found at http://support.microsoft.com/default.aspx?scid=kb;EN-US;250987.
Cause
One of the database machines was duplicated or cloned from another machine using a product such as VMWare or Ghost. As a result, the DTC GUID is not unique and the DTC instance cannot be uniquely identified. For more information about this problem, see Do Not Disk Duplicate Installed Versions of Windows from http://support.microsoft.com/default.aspx?scid=kb;EN-US;162001.
Additional Information
Formerly known as NETIQKB50360
If the DTC problem is not solved, perform a more thorough diagnosis using the steps described in the following Microsoft Knowledge Base Articles:
- Troubleshoot MS DTC Firewall Issues, which you can find at http://support.microsoft.com/default.aspx?scid=kb;EN-US;306843
- Troubleshooting Linked Server Error 7391, which you can find at http://support.microsoft.com/default.aspx?scid=kb;EN-US;306212
- Use DTCTester Tool, which you can find at http://support.microsoft.com/default.aspx?scid=kb;EN-US;293799