NetIQ AppManager experiences random software and functionality issues when installed on Microsoft Operating Systems that have been built using imaging software. (NETIQKB50016)

  • 7750016
  • 02-Feb-2007
  • 17-Nov-2010

Environment

NetIQ AppManager 6.x
NetIQ AppManager 7.0.x
Microsoft Windows Server 2003

Situation

NetIQ AppManager experiences random software and functionality issues when installed on Microsoft Operating Systems that have been built using imaging software.
NetIQ AppManager Modules, Agents, and/or Jobs fail at random or develop random problems on systems that were built using imaging software.
The following conditions may result in unexpected, seemingly random issues within the AppManager product, when deployed on an imaged system:
Deploying a Master Image created from a system which was not prepared for imaging using the Microsoft SysPrep tool.
Deploying a Master Image which contains any installed or copied files from the NetIQ AppManager product including Core Components, Modules or Agents.
Installing any AppManager component on a system that was imaged using a process that would otherwise be considered unsupported by Microsoft.

Resolution

Functionality of the AppManager Repository, Management Servers, Report Agents, Consoles, Modules, Agents and Jobs can not be guaranteed to be fully functional unless the following steps are used in the creation and deployment of Operating System  images to servers hosting any AppManager component:

  1. The Microsoft Sysprep utility tool must be run on the system being used to create the master image, prior to the image being created, and in accordance with Microsoft instructions and guidelines.
  2. The Master Image that is generated must not include any installed or copied NetIQ AppManager components or software.
  3. Any NetIQ AppManager components to be used on a newly imaged system must be installed on the system after the imaging process is completed, the server has been uniquely named, and the server has been successfully deployed to the network.

Cause

When a Microsoft Operating System is imaged, the process will inadvertently transfer Microsoft Security ID values (SIDs) from the master image onto those servers being built from that master image.

Typically, SID removal or duplication software is employed on a system which will be used to create the Master Image. Occasionally, the SID removal software will be run on the newly imaged system, in order to remove duplicate SIDs after-the-fact. Not all SID removal software is equal.  Many makes and types of SID removal software will correctly remove SIDs from the core Operating System.

The problem results from installed applications which may be a part of the Master Image and which may have copied SIDs from the Operating System for use by those applications. These additional copies of the SIDs may not be properly cleaned up by the SID removal software.

When one or more SIDs are duplicated to other servers, those duplicate SIDs can cause numerous problems on imaged systems.  Those problems may manifest themselves differently from one imaged system to another.  These seemingly random issues can negatively affect NetIQ AppManager and its components.

Per MS KB Article 162001 (found here: http://support.microsoft.com/kb/162001/):

-  Microsoft does not provide support for computers that have been installed by duplicating fully installed copies of Windows.  Microsoft supports computers that were installed by using disk-duplicating software and the System Preparation Tool (Sysprep.exe).

-  Microsoft supports the following operating systems that have been imaged by using the Sysprep utility:

  • Windows 2000 Professional
  • Windows 2000 Server (can only be imaged before you run DCPROMO)
  • Windows 2000 Advanced Server
  • Windows Server 2003, Standard Edition
  • Windows Server 2003, Enterprise Edition

-  Microsoft does not provide support for computers that were set up with SID duplicating tools other than the System Preparation (Sysprep) tool.

More information regarding Microsoft support of Imaged systems, and what steps Microsoft requires in order for an imaged copy of their Operating System to be supported by Microsoft can be located through the above linked MS KB Article.

Additional Information

Formerly known as NETIQKB50016

NetIQ AppManager, and its Core Components (such as the Repository, Management Servers, Report Agents and Consoles), as well as AppManager Modules, Agents and Jobs are dependant on a functional and error-free operating system to operate properly.  The third-party products that this article discusses are manufactured by companies that are independent of NetIQ. NetIQ makes no warranty, implied or otherwise, regarding the performance or reliability of these products.