Administration servers do not display Exchange 2000 or Exchange 2003 properties for user accounts wi (NETIQKB49820)

  • 7749820
  • 02-Feb-2007
  • 14-May-2007

Resolution

fact

Directory and Resource Administrator 6.x



fact
Directory and Resource Administrator 7.x

symptom
Administration servers do not display Exchange 2000 or Exchange 2003 properties for user accounts with Exchange mailboxes in domains where Exchange is installed.

symptom
Exchange support is installed and enabled in the managed domain and in DRA, and Assistant Admins can see and manage Exchange mailbox properties for user accounts when connecting to some Administration servers, but cannot see and manage Exchange mailbox properties for the same user accounts when connecting to other Administration servers.

symptom
Assistant Admins cannot see or manage Exchange mailbox properties for user accounts even though Exchange is installed in the managed domain, user accounts have Exchange mailboxes, and Exchange support is enabled in DRA.

cause
When you enable Exchange support on an Administration server, each time the NetIQ Administration Service starts, it queries for a global catalog server in the managed domain. If the NetIQ Administration Service on an Administration server has previously obtained Exchange information from a global catalog server, and if that global catalog server is no longer available, the Administration server can no longer obtain Exchange information and DRA user interfaces connecting to that Administration server cannot display Exchange properties for user accounts.

fix

To resolve this issue, ensure that the global catalog server that the Administration server contacts each time the NetIQ Administration server restarts is available and contains Exchange 2000 and Exchange 2003 attribute information.

To view the name of the global catalog server the NetIQ Administration service queries each time it starts:

  1. Open Windows Registry Editor.
  2. Expand HKEY_LOCAL_MACHINE> SOFTWARE> Mission Critical Software> OnePoint> Administration> Modules> Accounts> Domains.Dns.
  3. Select the managed domain.
  4. Verify the global catalog server name listed in the GcsServer value.
  5. If the global catalog server name listed in the registry is the name of the global catalog server that is no longer available, edit the GcsServer value in the registry.
    1. Select GcsServer.
    2. On the Edit menu, click Modify.
    3. In the Value field, type the name of an available global catalog server.
    4. Click OK.
    5. Close Registry Editor.
    6. Restart the NetIQ Administration Service.

Editing the GcsServer value in the registry and restarting the NetIQ Administration Service ensures that the NetIQ Administration Service no longer queries for the unavailable global catalog server each time it restarts.



note
Warning: Using the Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. NetIQ cannot guarantee that problems resulting from the incorrect use of Registry Editor can be resolved. Make sure that you backup your Registry prior to making any changes.

Additional Information

Formerly known as NETIQKB49820