Why does the Windows Management Installer (WMI) service repeatedly start and stop when an Analytics_ (NETIQKB49447)

  • 7749447
  • 02-Feb-2007
  • 07-Jan-2011

Environment

NetIQ Appmanager 6.x
NetIQ Appmanager 7.0.x
AMPP 4.1.2

Situation

Running the Analytics_CompleteNTCounters KS results in repeated entries in the Application Event Log that indicate that the Windows Management Installer (WMI) services has started and stopped.

Resolution

If you do not want the WMI service to start and stop each time the Analytics_CompleteNTCounters job runs, then set the service to run automatically. Keep in mind that if the WMI service runs automatically, the service might consume additional system resources.



Cause

WMI is set to run manually. The WMI counter is one of the Performance Counters being pulled by the Analytics_CompleteNTCounters job. When the job runs, Windows starts the service to collect a counter value from PerfMon, which is then handed to the Analytics_CompleteNTCounters job. Windows will then stop the WMI service until the next time the job runs.

The default startup value for the WMI service was changed from automatic in Windows 2000 to manual in Windows 2003 to reduce the resources being used by this service.


Additional Information

Formerly known as NETIQKB49447