Environment
NetIQ AppManager Control Center 6.x
NetIQ AppManager Control Center 7.0.x
Situation
The NetIQ AppManager Control Center Command Queue service fails with an error.
The NetIQ AppManager Control Center Command Queue service will not start.
Error: "Service cannot be started. System.InvalidOperationException: Service AppManager Control Center Command Queue Service was not found on computer '.'. ---> System.ComponentModel.Win32Exception: The specified service does not exist as an installed service."
The NetIQ AppManager Control Center Command Queue service will not start.
Error: "Service cannot be started. System.InvalidOperationException: Service AppManager Control Center Command Queue Service was not found on computer '.'. ---> System.ComponentModel.Win32Exception: The specified service does not exist as an installed service."
Resolution
To add a new account to the Control Center Administrators Group:
- Log into Control Center using an account that is already a member of the Administrators Group.
- On the File menu, click Manage Security.
- In the Security window, click Users.
- Click Add to place the account in the Users list.
- Click User Groups.
- Click Add to place the user in the Administrators group.
Cause
The Logon As account you are using to start the Command Queue service is not listed within the Administrator Group in Control Center. You can confirm this is the problem by attempting to login to Control Center using the same account used to start the Control Center Command Queue service. If the logon fails, add this account to the Control Center Administrators Group.
Additional Information
Formerly known as NETIQKB49363
Control Center will not validate the user's permissions until that user attempts to log into the Control Center Console for the first time.