Sending a report with an Action Knowledge Script to the printer fails. (NETIQKB49308)

  • 7749308
  • 02-Feb-2007
  • 12-Jan-2011

Environment

NetIQ AppManager 6.x
NetIQ AppManager 7.0.x

Situation

Tthe Action_SendReportToPrinter is producing the following message, Error: 'Access denied attempting to launch a DCOM Server.'

The Windows EventViewer also contains the following message, 'Event ID 10002 with Source DCOM.'

Resolution

To grant access rights to the service account using the DCOM Configuration Utility:

  1. Click Start > Run > DCOMCNFG.
  2. Edit the Access Permissions to add the NetIQ Service account listed in the error for both Local and Remote access.
  3. Edit the Launch Permissions to add the NetIQ Service account listed in the error for both local and remote access.
  4. Restart the job to activate the action.
  5. If the action receives the same error message, restart both agent services or reboot the server to ensure the modified DCOM permissions are applied.

Cause

The service account listed in the error does not have the DCOM permissions needed to print to the local server.

Additional Information

Formerly known as NETIQKB49308