AMAdmin_AgentHealth not reporting events. (NETIQKB49230)

  • 7749230
  • 02-Feb-2007
  • 27-Jan-2011

Environment

NetIQ AppManager 6.x
NetIQ AppManager 7.0.x
AMAdmin_AgentHealth Knowledge Script

Situation

Cannot get information on the health of the agent.

AMAdmin_AgentHealth Knowledge Script does not report problems with the agent.

Resolution

To have the AMAdmin_AgentHealth Knowledge Script monitor more events than the default cold starts:

  1. Check out the AMAdmin_AgentHealth Knowledge Script. For more information, see the NetIQ Knowledge Base article
    NETIQKB9763: "How do I check out Knowledge Scripts from the AppManager Repository (QDB)"? at www.netiq.com/kb/esupport/consumer/solutionarea.asp?id=NETIQKB9763.
  2. Save the QML file to a different name so you will not overwrite the original.
  3. Look for the following line of code:
    lError = gobjNtEvents.SetFilter("EVENTIDS", "263,264", sError) 
  4. Add any event IDs you wish to monitor as follows:
    lError = gobjNtEvents.SetFilter("EVENTIDS", "263,264,<NewEventID>", sError)
  5. Check in the new AMAdmin_AgentHealth script. 
    For more information, see the NetIQ Knowledge Base article NETIQKB3082: "How do I check in a Knowledge Script (KS) or Knowledge Script Group (KSG) via the command line?" at www.netiq.com/kb/esupport/consumer/solutionarea.asp?id=NETIQKB3082.
  6. Drop the new AMAdmin_AgentHealth script on an agent you want to monitor.

Cause

By default, the AMAdmin_AgentHealth Knowledge Script only monitors Event IDS 263 and 264, which are NetIQmc cold start and NetIQccm cold start. Other actions, such as warm starts or communication issues, must be specifically set.

Additional Information

Formerly known as NETIQKB49230