The Diag_StartCollectionExchange Knowledge Script generates an error. (NETIQKB49032)

  • 7749032
  • 02-Feb-2007
  • 13-Dec-2010

Environment

NetIQ AppManager 6.x
NetIQ AppManager 7.0.x
NetIQ AppManager Diagnostic Console 2.x

Situation

The Diag_StartCollectionExchange Knowledge Script generates an error.
Error: 'Failed to load Exchange module.'

Resolution

Manually register the qDiagExcha.dll file on the target agent. In this case, the target agent is the agent on your Exchange server.

To manually register this file:

  1. Close any Diagnostic Consoles
  2. Go to Start > Run on the target machine
  3. Enter the following command:

    regsvr32 "C:\Program Files\NetIQ\AppManager\bin\qDiagExcha.dll"

You should see a message that the dll file was successfully registered. Once it is registered, start the Diagnostic Console and connect to your target Exchange server to view the Exchange diagnostic data.

Cause

The Diagnostic Console managed object qDiagExcha.dll was not registered during the agent install.

Additional Information

Formerly known as NETIQKB49032