Cannot start the NetIQ VigilEnt Agent 5.0 service. (NETIQKB48798)

  • 7748798
  • 02-Feb-2007
  • 17-Apr-2008

Resolution

fact
NetIQ Vulnerability Manager Agent for Windows 5.0

fact
NetIQ Vulnerability Manager Agent for Windows 5.5

fact
NetIQ Vulnerability Manager 5.5

symptom
Cannot start the NetIQ VigilEnt Agent 5.0 service.

symptom
Error: 'The procedure entry point ?q_pllSCategory @@3PAULogCategory@@ could not be located in the dynamic link library vsawn_utility.dll.'

change
NetIQ Vulnerability Management Agent for Windows 5.5 installation failed.

cause
Files from failed installation of NetIQ Vulnerability Management Agent for Windows 5.5 cause problems when attempting to install the 5.0 agent on a Windows NT Machine.

fix

Perform a clean installation of the 5.0 agent. There are three steps to a clean install:

  1. Uninstall the agent.
  2. Remove all file and registry traces left by the uninstall program.
  3. Reinstall the agent.

To uninstall the agent:

  1. Click Start > Control Panel > Add Remove Programs.
  2. Select NetIQ VigilEnt Agent for Windows v5.0.
  3. Click Change/Remove to display the NetIQ Uninstall wizard.
  4. Click Select All then Next.
  5. Click Yes in response to Are you sure you want to uninstall selected components?
  6. Once the uninstall process is finished, click Finish.

To remove all files and registry entries uninstall:

  1. Open My Computer.
  2. Select the C:\Program Files folder.
  3. If you don't have any other NetIQ products installed on your machine, delete the NetIQ folder.  If you have other NetIQ applications installed then open the NetIQ folder and delete only the Vulnerability Manager Agent folder.
  4. Click Start > Run.
  5. Enter regedit then click OK to open the Registry Editor.
  6. Expand HKEY_LOCAL_MACHINE > SOFTWARE. 
  7. If you don't have any other NetIQ products installed on your machine delete the NetIQ registry key.  If you have other NetIQ applications installed then expand the NetIQ node and delete the VigilEnt registry key.

After completing all the steps above, reinstall the 5.0 agent on this machine.



Additional Information

Formerly known as NETIQKB48798