Database Connection error occurs when you attempt to run a report (NETIQKB48648)

  • 7748648
  • 02-Feb-2007
  • 15-Mar-2013

Environment

NetIQ Group Policy Guardian 2.0

Resolution

fact
NetIQ Group Policy Guardian 2.0

symptom
Database Connection error occurs when you attempt to run a report

symptom
When you attempt to run a report from a stand-alone GPG Reporting computer, the following error may occur: "Error opening database connection: The partner transaction manager has disabled its support for remote/network transactions."

cause

DTC access is not enabled



fix

To address this issue, perform the following steps in the order specified.

From the GPG Database computer:

  1. Start Add/Remove Programs in Control Panel.
  2. Click Add/Remove Windows Components.
  3. Select Application Server and click Details.
  4. Select Enable network DTC access and click OK.
  5. Click Next to install the component.
  6. Click Finish then close Add/Remove Programs.
  7. Start Component Services in Administrative Tools.
  8. Expand Component Services > Computers.
  9. Click My Computer and select Properties from the Action menu.
  10. Click the MSDTC tab.
  11. Click Security Configuration at the bottom of the window.
  12. Under Security Settings, select Network Transactions.
  13. Click OK.
  14. Click OK again then close Component Services.

From the GPG Reporting computer:

  1. Start Add/Remove Programs in Control Panel.
  2. Click Add/Remove Windows Components.
  3. Select Application Server and click Details.
  4. Select Enable network DTC access and click OK.
  5. Click Next to install the component.
  6. Click Finish then close Add/Remove Programs.
  7. Start Component Services in Administrative Tools.
  8. Expand Component Services > Computers.
  9. Click My Computer and select Properties from the Action menu.
  10. Click the MSDTC tab.
  11. Click Security Configuration at the bottom of the window.
  12. Under Security Settings, select Network Transactions.
  13. Click OK.
  14. Click OK again then close Component Services.  

From the GPG Server computer:

  1. Start Services in Control Panel.
  2. Stop the NetIQ GPG Control Service and NetIQ GPG Host Service.
  3. Stop the Messaging Queuing service.

From the GPG Database computer:

  1. Stop the Distributed Transaction Coordinator service.
  2. Stop the MSSQLSERVER service.
  3. Start the MSSQLSERVER service.
  4. Start the Distributed Transaction Coordinator service.

From the GPG Reporting computer:

  1. Stop the Distributed Transaction Coordinator service.
  2. Start the Distributed Transaction Coordinator service.

From the GPG Server computer:

  1. Start the Message Queuing service.
  2. Start the NetIQ GPG Control Service and NetIQ GPG Host Service.

After you complete these steps, the reports should run without error.



Additional Information

Formerly known as NETIQKB48648