I receive an error when attempting to run a Security Patches Not Applied check on a Red Hat AS 4.0 c (NETIQKB48438)

  • 7748438
  • 02-Feb-2007
  • 10-Oct-2007

Resolution

fact
NetIQ Vulnerability Manager 5.0

fact
VigilEnt Security Agent for Unix 5.0

fact
Red Hat Linux AS 4.0

symptom
I receive an error when attempting to run a Security Patches Not Applied check on a Red Hat AS 4.0 computer.

symptom
Error: 'Unable to stat file ./vsau/data/datafiles/patches.Linux.redhat.4.dat'

symptom
I can't run a particular VM security check on my Red Hat Linux computer.

cause

The 'unable to stat' part of the message indicates that the patches.Linux.redhat.4.dat file is not there, is corrupt, or is in some other way unusable. Red Hat Linux AS 4.0 was not released until after the initial release of the VigilEnt Security Agent for Unix 5.0 and therefore was not certified until after the 5.0 Security Agent release.



fix

You can retrieve the updated patches.Linux.redhat.4.dat file using the AutoSync Wizard in the Vulnerability Manager console. See the Vulnerability Manager User Guide for more information about using the AutoSync function.

Alternatively, you can copy the Red Hat Linux AS 3.0 files below from their default locations and rename them as redhat.4 files:

  • $PSHOME/vsaunix/{OS}/vsau/data/datafiles/patches.Linux.redhat.3.dat
    copy to $PSHOME/vsaunix/{OS}/vsau/data/datafiles/patches.Linux.redhat.4.dat
  • $PSHOME/vsaunix/{OS}/vsau/data/datafiles/patches.Linux.redhat.3.0AS.dat
    copy to $PSHOME/vsaunix/{OS}/vsau/data/datafiles/patches.Linux.redhat.4.0AS.dat

Note, however, that AutoSync is the recommended method for obtaining the patch file, as the AutoSynced file has the most up-to-date security patch information.



Additional Information

Formerly known as NETIQKB48438

Feedback service temporarily unavailable. For content questions or problems, please contact Support.