The 432 file name or class name not found during OLE operation. (NETIQKB48240)

  • 7748240
  • 02-Feb-2007
  • 24-Jan-2011

Environment

NetIQ AppManager 6.x
NetIQ AppManager 7.0.x
Microsoft Exchange Server 2003

Situation

The 432 file name or class name not found during OLE operation.
Error: '432 file name or class name not found during OLE operation'

Resolution

In most cases, this error is caused by a mismatch between the versions of the Managed Object and the Knowledge Scripts.  For every Managed Object update, the MO must be installed on the AppManager Repository and the Agent that runs the MO (such as the Agent monitoring an Exchange server).

To verify the Knowledge Script itself:

    1. Confirm the Exchange Managed Object (Qexch2k1a.EXE) is running the most up to date version (check the AppManager Module upgrades page for the latest version: https://www.netiq.com/support/am/extended/modules.asp)
    2. Verify that the same update was performed on the Repository QDB Server and the Script version history reflects the correct version.  You can right-click the Agent machine in the Operator Console Tree View and click Properties.
    3. Check the version history and the location of the Knowledge Script you are using.  Customized Knowledge Scripts may not respond when used on an updated MO. 
    4. Drop a new, unmodified Knowledge Script for testing purposes to verify that it is not an issue related to the existing job script

If the KS appears to be valid, confirm the AM Agent settings and registry keys:

  1. On the Exchange Server Managed Client
  2. Log on to the Server with the AppManager service account
  3. Go to Start | Run | Regedit
  4. When the registry editor comes up, certify the existence of the following Key:

HKEY_Classes_Root\NetIQAgent.<servername>\CLSID

If it exists write down the "data" number and look for the ProgID by verifying

HKEY_Classes_Root\CLSID\{WrittenNumberYouTookDown}\ProgID

More than likely one or more of these is missing.  If it is missing, re-install the Agent and "replace all components" during the install.  After re-installing, verify the existence of these keys and re-run the Exchange Discovery.

Cause

This issue can occur if the Managed Object version does not match the version on the Knowledge Scripts.

Exchange 2000/2003 Knowledge Scripts can not find the NetIQ Agent registry key.

Additional Information

Formerly known as NETIQKB48240